UPDATE -- Ruby on Rails has released Version 1.1.6, one day after after discovering that Version 1.1.5 didn't completely close the security hole. That vulnerability, the
The authors have also posted patches for older versions for those who can't update.
A serious security vulnerability has forced the creators of Ruby on Rails to issue an immediate upgrade for the software. Version 1.1.5, which is being called a mandatory upgrade, is available now.
Rails 1.0 and prior, as well as 1.1.3, are not affected. The creators are still trying to determine how contaminated 1.1.0, 1.1.1, 1.1.2, and 1.1.4 are.
The vulnerability is so critical that the creators aren't disclosing any details so as to prevent attacks and protect people who are still in the process of upgrading.
Rails 1.1.5 is fully drop-in compatible with 1.1.4. It includes only a few bug fixes and no new features.
"As always, the trick is to do 'gem install rails' and then either changing config/environment.rb, if you're bound to gems, or do "rake rails:freeze:gems" if you're freezing gems in vendor," according to the advisory in the blog posting.
The creators are continuing their investigation into the breach and promise to issue a full report once it's complete and people have had enough time to upgrade.